What happens if I don’t upgrade my device to be compatible with TLS 1.2?

If after the 26th June 2018 you attempt to shop on a non-TLS 1.2 compatible device, you will not be able to load or access the page required to add your payment details. In the near future you will not be able to view or log into our website.

Do you need to contact us?

Back to Technical Information