Who will the TLS 1.2 security update affect?

The small number of people who will be affected are those who shop using the following devices - any machine running windows XP (or older) and/or Android devices which are version 4.x.

Do you need to contact us?

Back to Technical Information