I have a non-TLS 1.2 compatible device what should I do?

From 26th June 2018, if you use a device to shop online that does not support TLS 1.2 you will notice that you will not be able to load web pages or submit payment details. Most devices are already compatible, so you shouldn’t have to worry about anything.

Was this information useful?

Back to Technical Information